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THE INTEGRATED DELL REMOTE ACCESS CONTROLLER 9 (IDRAC9) WITH LIFECYCLE CONTROLLER

~ COMPLETE AGENT-FREE
A MANAGEMENT OF

POWEREDGE SERVERS

Dell IDRACY provides security
and intelligent automation.

Modernize with the Dell EMC PowerkEdge portfolio

The integrated Dell Remote Access Controller 9 (IDRACS) delivers advanced, agent-free local and remote server administration
o Embedded in every PowerEdge server, IDRACY provides a secure means to automate a multitude of common management tasks
Because IDRACSY is embedded in every Powerkdge server, there's no additional software to install, just plug in power and network
- cables, and IDRACS is ready to go. Even before installing an operating system or hypervisor, IT administrators have a complete set
of server management features at their fingertips: Maximize storage performance with up to 12 NVMe drives and ensure application
5 performance scales easily

i « Configuration + Firmware updates + Automation of other routine

= 08 deployment « Health monitoring management activities

Scalable Architecture

With iDRACSY in place across the PowerEdge portfolio, the same IT administration technigues and tools can be applied throughout

This consistent management platform allows easy scaling of PowerEdge servers as an organization's infrastructure needs grow
Customers will be able to use the iIDRAC RESTful API for the latest in scalable administration methods of PowerEdge servers. With this
API, IDRACS enables support for the Redfish standard and enhances it with Dell EMC extensions to optimize at-scale management of
PowerEdge servers. Regardless of size though, the entire OpenManage portfolio of syslems management tools allows every customer
to tatlor an effective, affordable solution for their environment. This portfolio includes tools, consoles and integrations

Each component leverages iDRACY to make management easy By extending the reach of administrators to larger numbers of servers,
that staff becomes more productive and drives down costs

Intelligent Automation

= Dell's agent-free management puts IT administrators in control. Once a PowerEdge server 1s connected to power and networking, that
system can be monitored and fully managed, whether you're standing in front of the server or remotely over a network. In fact, with no
need for software agents, an IT administrator can

- + Monitor + Manage + Update + Troubleshoot and remediate Dell EMC servers

With features like zero-touch deployment and provisioning, iDRAC Group Manager, and System Lockdown, iDRACS is purpose-built to
make server administration quick and easy. For those customers whose existing management platform utilizes in-band management,
i Dell EMC does provide iDRAC Service Module, a lightweight service that can interact with both IDRACS and the host operating system
to support legacy management platforms

Secure Local and Remote Management

Whether IDRACY is used via the updated, HTML5-based web interface, command line interface, or via a set of robust APIs such as
the IDRAC RESTful API, securty is ensured with HTTPS, SSL, Smart Card authentication, LDAP, and Active Directory integration. The
=5 iDRACS web interface, remote RACADM utility, and WS-MAN interfaces all support TLS 1 2. Every web page served by the iDRACS is
delivered with TLS encryption at 256-bit strength (unless configured otherwise). Dell also supporis encryption on the virtual KVM {wvirtual
= console redirection) and virtual media over TLS. The iDRACS virtual console and media also benefit from SSL encryption. Additionally,
the IDRACS firmware is equipped with a default security certificate, which can be replaced by one of a customer’s choosing. By
providing secure access remote servers, administrators can carry out critical management functions while maintaining the integrity and
security of their data.



The Heart of PowerEdge Manageability

The IDRACY provides common, embedded management across the PowerEd
grow, and ensure security for peace of mind. This is why iDRAC is the core of mana

technologres in the OpenManage portfolio, a customer can build a management solution that matches their needs, and by leveraging
IDRACS, ensures oplimal server management.

BIOS Recovery
Connection View

Full Power Cycle

IDRAC Direct

IDRAC Group Manager

IDRAC RESTful API
Multi Vector Cooling
OpenManage Mobile and
Quick Sync 2

System Erase

System Lockdown

Zero touch deployment
and provisioning

Detect an invalid, untrusted BIOS image when a boot is attempted and recover to an authenticated, trusted BIOS Image

Quiickly check if server LOMS/NDCs and IDRAC are cannected to the correct switches and parts via the GUI or by command
line interface This helps prevent costly remote dispateh of technicians to remediate cabling errors

By utihzing the IDRAC Service Module (iISM), DC power, including AUX power, can be termnporarily reroved via local or
remote control to rasel all power nodes in a server, saving lime when troubleshooting

Secure front-panel USB connection to IDRAC web interface which eliminates the need for crash carts or a trip to the hot
asle of your data center. You can use the same porl fo inserl a USE key to upload new system profile for secure. rapid
system configuration

Provides bullt-in, one-to-many menitonng and inventory of local IDRACSs with no software to Install  Ideal for customers
wha don't want to install and maintain a separate monitoring console. This feature does require IDRAC Enterprise licenses

With this AP1, IDRAC enables support for the Redfish standard angd enhances it with Dell extensions

Airflow for each PCle slot can be fine-tuned to ensure proper cooling. This allows for greater power efficiency and more
precise cooling within each server for accessory cards

Use the OpenManage Mobile 2 0 (or higher) app on your handheld device to securely retrieve critical health data and easily
perform bare-metal server configuration tasks via BLEMW-Fi connectivity. Compatible with vanous i0S and Android devices.

With proper authentication, adminislratars can securely erase data from local storage (HDDs, SSDs, NVMs) and embedded
flash devices.

Helps to prevent configuration or firmware changes 1o a server when using Dell tools. Requires IDRAC Enterprise License.
When ordered with DHCP enabled from the factory, PowerEdge servers can be automatically configured when they are

initially powered up and connected to your netwark. This process uses profile-based configurations that ensure each server
is configured per your specifications. This feature requires an iIDRAC Enterprise license.

iDRAC Licenses / 200-500 Series Rack /

Server Model Towar 600+ Rack/Tower Modular
Basic Standard nia n/a
Express Optional Standard n/a
Express for Blades nia n/a Standard
Enterprise Upgrade Upgrade Upgrade

Learn more at
dell.com/poweredge and
delltechcenter.com/idrac

ge family of servers, automation that lets your organization
ging Dell EMC servers, From the variety of tools and
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New features in yellow

License Type

iDRAC 9 License Levels and Features

Express

Express for Blades

Enterprise

Interfaces | Standards

Folicy Banner - login page

Redfish v v v
1P 2.0 v v % v
DCMI 1.5 v v v

b-based GUI v v P v
Racadm command line v ¥ L v
(localfremote)
SMASH-CLP (SSH-onily) v V S -
Telnel v v v o
SSH v v v v
Senal Redirection ' v v v
WSMAN v 3 v v
Network Time Protocol v 4

Connectivity
Shared NIC v v N/A v
Dedicated NIC v v of W,
VLAN tagging v . v v
IPwvd v v v v
IPvE v v v v
DHCP (new default; not v v v v
static I1P)
DHCP with Zere Touch v
Dynamic DNS v v v
08 pass-through v v v v
IDRAC Direct - Front panel v v v v
use
Connection View v 4 v
NFS vd v v v ,,/
SMB3.0 with NTLMv1 and 4 v v v
NTLMy2
Security

Role-based authority v W v L
Lacal users v v v W
SSL encryption v v ¥ '
IP blocking o v v
Directory services (AD ¥
LDAP)
Two-factor authentication v
Single sign-on v
PK authentication v v v
Secure UEF] boot - v b Y ¥
certificate management
Lock down mode i
Unique IDRAC default v v v v
password
FIPS 140-2 v o 7 7
Customizable Security v v v v




IDRAC 9 License Levels and Features

License Type Basic Express Express for Blades | Enterprise
Quick Sync 2.0 - optional v v v
auth for read operations
Quiick Sync 2.0 - add mobile v v v
device number to LCL
Systern Erase of inlernal o v v
slarage devices

Remote Presence
Power control v v ¥
Bool control « v
Serial-over-LAN o v v
Virtual Media v v
Virtual Folders v
Remote File Share v
Virtual Console v %
HTMLS access to Virtual v ¥
Console
WVNC connection to 08 v
Quality/bandwidth control v
Virtual Console v
collaboration (6 users)
Virtual Console chat v
Virtual Flash partitions v
Group Manager v
HTTP / HTTPS support v v v
along with NFS/CIFS

Power & Thermal
Real-time power meter v v v
Power thresholds & alerts v v v
Real-ime power graphing v v v
Hislorical power counters v v v
Power Capping v
Openianage Power Cenler v v v
integration (view (Jl'l|\."_|
Temperature monitonng v v v
Temperature graphing v % v

Health Monitoring
Full agent-free monitaring v v v
Predictive fallure monitoring v v v
SNMPv1, v2, and v3 (traps v v v
and gets)
Email Alerting v v v
Configurable thresholds v v v
Fan monitanng v v v
Fower Supply moenitaring v v v
Memory monitoring v v v
CPU monitoring v v v
RAID manitonng v v v
NIC monitoring v v v
HD monitoring (enclosure) v v v
Out of Band Performance v
Monitoring
Alerts for excessive SSD e v v

wear




iDRAC 9 License Levels and Features

License Type Basic Express Express for Blades Enterprise
Cusiomizable settings for v v v
Exhaust Temperature
Update

Remote agent-free update v v v
Embedded update tools ¥ v v
Sync with repository v
(scheduled updates)
Auto-update v
Improved PSU firmware v v v
updates

Deployment & Configuration
Local configuration via F10 v v v
Embedded OS deployment v v W
tools
Embedded configuration v v o
toonls
Auto-Discovery v 4 v
Remote OS5 deployment v v v
Embedded driver pack ¥ , v
Full configuration inventory v ¥ v
Inventory export v v v
Remate configuration v v v
Zerotouch configuration v
System Retire/Repurpose ¥ ¥ v
Server Configuration Profile v v v
in GU!

iagnostics, Service & Logging
Embedded diagnostic tools v v o
Part Replacement ¥ ¥ v
Server Configuration v
Backup
Server Configuration ¥ ¥ v
Restore
Easy Restore (system v v v
configuration)
Easy Restore Auto Timeout v v v
Health LED / LCD (requires v NIA .
optional bezel)®
Quick Sync (require NFC
hezel, 136G only)
Ciuick Syne 2.0 {requires v v v
optional BLEAF
hardware)
IDRAC Direct (front USB v ¥ v
management port)
iDRAC Service Module v v v
(ISM) embedded
Alert forwarding via iSM to v v v
inband monitoring consoles
Crash screen capture v v v
Crash wideo capture * v
Boot capture v
Manual reset for IDRAC ¥ v v
(LCD 1D button)
Remote reset for iDRAC v v L
(requires iSM)
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iIDRAC 9 License Levels and Features
License Type Basic Express Express for Blades | Enterprise b
Virtual Nl v v v v G
0S8 watchdog * v v % (
S
SupportAssist Report v o e v
(emhbedded) .
Syslem Event Log v v v 2 0
Lifecycle Log ¥ v v v
- —
Enhanced Logging in v v v v
Lifecycle Controller Log (
o
Work notes v v v v
v . e
Remote Syslog v
License management v v v v e
Improved Customer Experience o
IDRAC -Fasler processor, v v v v !
more memaory e
GUI rendered in HTMLS5 v e o 7 w
Add BIOS configuration to v v v v
IDRAC GUI S~
IDRAC support for SW v % v v o
RAID licensing
fooinotes b=
1 Mot avaiable with blade servers \
2 500 series and lower rack and lower servers require a hardware card o enable this feature this hardware offered at additional cost s

Requires vFlash S0 card media L

~ ~ A aa S
Requires IDRAC Service Module (iISM) or OpenManage Server Administrator (OMSA)
Requires oplional beze!
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* Leasing and financing provided and serviced by Dail Financlal Services LG, or #5 affiliste or designes (TDH for qualified customers. Offers may nol be availabhe o may vary
In certain countries. \Whers available, offers may be chapged without notice'and are subject to product Hity, Credit approval, exscution of documentation provided by and

acceptabls io.DFS, and may be subject {o minimum transaclion size, Offers not avallable for persanal, famlly or household use, M-L E M C
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Notes, cautions, and warnings

@1 NOTE: A NOTE indicates important infarmation that helps you make better use of your product.

A CAUTION indicates either potential damage to hardware or loss of data and tells you how to avoid
the problem.

&! WARNING: A WARNING indicates a potential for property damage, personal injury, or death.

© 2022 Dell Inc. or its subsidiaries. All rights reserved. Dell. EMC, and other trademarks are trademarks of Dell Inc. or its subsidiaries. Other
trademarks may be trademarks of their respective owners,



Revision history

The following table shows the revision history of this document:

Revision | Date Description

1 February 2022 Content updated for this release of OpenManage Enterprise.

Revision history 3




Preface

As part of an effort to improve product lines, we periodically release revisions of software. Therefore, some functions described
in this document might not be supported by all versions of the software currently in use. The product release notes provide the
most up-to-date information on product features.

Contact your technical support professional if a product does not function properly or does not function as described in this
document.

@ NOTE: This document was accurate at publication time. Go to Online Support (htips://www.dellcom/support ) 1o ensure
that you are using the latest version of this document.

Purpose

This document includes conceptual information on managing OpenManage Enterprise.

Audience

This document is intended for use by administrators, device managers, and viewers who use OpenManage Enterprise for
systems management and menitoring.

Related documentation

The following publications provide additional information:

OpenManage Enterprise Support Matrix

OpenManage Enterprise Release Notes

OpenManage Enterprise Security Configuration Guide

OpenManage Enterprise User's Guide

OpenManage Enterprise RESTful APl Guide

OpenManage Enterprise RESTful APl at https://developer dell com/aps.
OpenManage Enterprise Modular Edition Release Notes

OpenManage Enterprise Modular Edition RESTful API Guide

In addition to the core documents, we also provide white papers, plugin documentation and demos on YouTube,

Typographical conventions

This document uses the following style conventions:

Bold Used for names of interface elements, such as names of windows, dialog boxes, buttons,
fields, tab names, key names. and menu paths (what the user specifically selects or clicks)

Italic Used for full titles of publications referenced in text

Monospace Used for:

e System code

e System output, such as an error message or script
e Path names. filenames, prompts, and syntax

e Commands and options

Monospace italic Used for variables
Monospace bold Used for user input

[ Square brackets enclose optional values
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Vertical bar indicates alternate selections - the bar means "or"
Braces enclose content that the user must specify, such as x ary or z

Ellipses indicate nonessential information amitted from the example

Product documentation

Q)I NOTE: For video demos and tutoerials, search for the Uell LWIC Openidanage Lnterprise playlist on YouTube.,

For OpenManage Enterprise. go to hitps/Swww dell com/openmanangemantials,
To display the documentation of:
o Dell EMC OpenManage Enterprise, click
Dell OpenManage Enterprise > Dell EMC OpenManage Enterprise > Documentation.
o Dell EMC OpenManage Mobile, click
OpenManage Mobile > Select the required version > Documentation,
For OpenManage Enterprise plugins, go to hitps//www. dell com/openmanagemanuals,

l'o display the documentation of:

> Dell EMC OpenManage Enterprise Services plugin, click

OpenManage Enterprise Connected Services > OpenManage Enterprise Services > Documentation.

o]

Dell EMC OpenManage Enterprise Power Manager plugin, click

OpenManage Enterprise Power Manager > Dell EMC OpenManage Enterprise Power Manager >
Documentation.

o Dell EMC OpenManage Enterprise Update Manager plugin, click

OpenManage Enterprise Update Manager > OpenManage Enterprise Update Manager > Documentation.

C

Dell EMC OpenManage Enterprise Cloud!@ plugin, click

OpenManage Enterprise Connected Services > OpenManage Enterprise Cloud|@ > Documentation.
For OpenManage Enterprise APls, go to https://developor.dell com/products,

To display the APl documentation of:

o Dell EMC OpenManage Enterprise, click Servers > OpenManage Enterprise API
o Dell EMC OpenManage Enterprise Modular Edition, click Servers > OpenManage Enterprise Modular API
o Dell EMC OpenManage Enterprise Services plugin, click Servers > OpenManage Enterprise Services API.

Dell EMC OpenManage Enterprise Update Manager plugin, click Servers > OpenManage Enterprise Update Manager
API

Dell EMC OpenManage Enterprise Power Manager plugin, click Servers > OpenManage Enterprise Power Manager
API

Dell EMC OpenManage Enterprise Cloud!@ plugin, click Cloudl@ Public API

o

o]

Product information

For documentation, release notes, software updates, or information about products, go to Online Support at hitips /s

wwwdell com/support,

Where to get help

Go to Online Support at www.dell com/support and click Contact Support. To open a service request, you must have a valid
support agreement. Contact your sales representative for details about obtaining a valid support agreement or with questions
about your account.

wn
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Where to find the support matrix

Consult the Support Matrix on Dell OpenManage Enterprise at hiips://www dall com/openmanagemanuals and click
Documentation.

Your comments

Your suggestions will help us continue to improve the accuracy, organization, and overall quality of the user publications. Send
your opinions of this document to https://contentfeedback dell.cam/s,
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About Dell EMC OpenManage Enterprise

OpenManage Enterprise is a systems management and monitoring web application delivered as a virtual appliance. It provides
a comprehensive view of the Dell EMC servers, chassis, storage, and network switches on the enterprise network, With
OpenManage Enterprise, a web-based one-to-many systems management application. users can:

e Discover devices in a data center environment.

e \View hardware inventory and monitor health of devices.

e View and manage alerts received by the appliance and configure alert policies.

e Monitor firmware / driver versions and Manage firmware / driver updates on devices with firmware baselines,
e Manage remote tasks (such as power control) on devices.

e Manage configuration settings across devices using deployment templates.

e Manage virtual identity settings across devices using intelligent identity pools,

e Detect and remediate configuration deviations across devices using configuration baselines.

e Retrieve and monitor warranty information for devices.

e Group devices into static or dynamic groups.

e Create and manage OpenManage Enterprise users.

@ NOTE:
e OpenManage Enterprise's system management and monitoring is best suited for enterprise LANs and is not

recommended for usage over WANSs.

e Forinformation about supported browsers, see the OpenManage Enterprise Support Matrix available on the support
site.

Some of the security features of OpenManage Enterprise are:
e Role-based access that limits access to console settings and device actions.

e Scope based access control allows administrators to restrict the device groups that device managers can access and
manage.

Hardened appliance with Security-Enhanced Linux (SELinux) and an internal firewall.
Encryption of sensitive data in an internal database.

Use of encrypted communication outside the appliance (HTTPs).

Create and enforce firmware and configuration-related policies.

e Provision for configuring and updating the bare-metal servers.

OpenManage Enterprise has a domain-task-based GUI, where the navigation is designed by considering the sequence of tasks
that are predominately used by an administrator and device manager. When you add a device to an environment, OpenManage
Enterprise automatically detects the device properties, places it under relevant device group, and enables you to manage the
device. The typical sequence of tasks performed by OpenManage Enterprise users:
Install Openfanage Enterprise on page 22
Configure Openhanags Enterprise by using Text User Interface on page 29
Distovermg devices for monitonng or management on page 43
Manage devices and device groups on page 58
Monitor de v using the OpenManage Enterprise dashboard on page 40
25 nto groups on page b8
Manage the device firrmware and diivers on page 80
View and corfigure individual devices on page 72
M 1 alerts on page 124
and renew device warranty on page 145

Marage device deployment templates on page 90
Managing the device configuration compliance on page 116

wage complance templates on page 117
Manitor audit 1cgs on page 133
nManage Enterprise appliance settings on page 156
Hun an inventory job now on page 78
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o Manage the device warranty on page 145

Heports on page 147

e Managing MIB files on page 153

s  Role and e based access control m OpenManage Enterprise on page 18
services ntegration in OpenManage Enterprise on page 165

o [ectory
Topics:

. Openianage kEnterpr Al 1 llcense

. License based featurs

age Lnterprse

OpenManage Enterprise Advanced license

@) NOTE: Installing and using OpenManage Enterprise does not require the OpenManage Enterprise Advanced license. Only
the server configuration management feature—deploying device configurations and verifying configuration compliance on
servers, requires that the OpenManage Enterprise Advanced license is installed on target servers. This license is not
reauired for creating deployment templates from a server.

The OpenManage Enterprise Advanced license is a perpetual license that is valid for the life of a server, and can be bound to

the Service Tag of only one server at a time. OpenManage Enterprise provides a built-in report to view the list of devices and

their licenses. Select OpenManage Enterprise > Monitor > Reports > License Report, and then click Run, See ~urroports

on page 148.

@ NOTE: Enabling the server configuration management feature in OpenManage Enterprise does not require any separate
license. If the OpenManage Enterprise Advanced license is installed on a target server, you can use the server configuration
management feature on that server,

OpenManage Enterprise Advanced license—Supported servers

You can deploy the OpenManage Enterprise Advanced license on the following Powertdge servers:
e YX3X servers having the iDRACS 2.50.50.50 or later firmware versions. The YX3X firmware versions are backward

compatible and are installable on YX2X hardware, See Genoric naming convention for Dell EMC Powerbdge servers on
page 197.

s YX4X servers having the iDRACS 3.10.10.10 or later firmware versions. See Geneiic naming convention for Dell L
FowerLdge servers on page 197

Purchase OpenManage Enterprise Advanced license

You can purchase the OpenManage Enterprise Advanced license when you purchase a server or by contacting your sales
representative. You can download the purchased license from the Software License Management Paortal at Dell corm/suppant /
retall/lkm.

Verify license information

OpenManage Enterprise provides a built-in report to view the list of devices monitored by OpenManage Enterprise, and their
licenses. Click OpenManage Enterprise > Monitor > Reports > License Report. Click Run. See ~un repor o an page 148.

You can verify if the OpenManage Enterprise Advanced license is installed on a server by:
e On all pages of OpenManage Enterprise, in the upper-right corner, click the i symbol, and then click Licenses.

e In the Licenses dialog box, read through the message and click appropriate links to view and download OpenManage
Enterprise related open-source files, or other open-source licenses.

License-based features in OpenManage Enterprise

The OpenManage Enterprise Advanced license is required to use the following features of OpenManage Enterprise:

About Dell EMC OpenManage Enterprise 15



Server configuration deployment.
Server configuration compliance baseline creation and remediation.
Boot to ISO.

Activate the available plugins, such as the Power Manager, to extend the capability of the appliance.

@ NOTE: To access features of the OpenManage Enterprise such as the Virtual Console Support function, which depends on

16

the iDRAC. you would need the iDRAC enterprise license. For more details, see the iIDRAC documentation available on the
support site.
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Security features in OpenManage Enterprise

Some of the security features of OpenManage Enterprise are:

Role-based access control allows different device management functionality for different user roles (Administrator, Device
Manager, Viewer).

Scope-based access control allows an administrator to determine the device groups that the device managers are expected
10 manage.

Hardened appliance with Security-Enhanced Linux (SELinux) and an internal firewall.

Encryption of sensitive data in an internal database.

Use of encrypted communication outside the appliance (HTTPS).

Only browsers with 256-bit eneryption are supported. for more information refer, Miimum system requirements o)
deploying Openivianage Lnterprise on page 23

A WARNING: Unauthorized users can obtain OS-level access to the OpenManage Enterprise appliance bypassing

Dell EMC's security restrictions. One possibility is to attach the VMDK in another Linux VM as a secondary drive,
and thus getting OS partition access, whereby OS-level login credentials can possibly be altered. Dell EMC
recommends that customers encrypt the drive (image file) to make unauthorized access difficult. Customers
must also ensure that for any encryption mechanism used, they can decrypt files later. Else, the device would
not be bootable.

@ NOTE:

e Any change to the user role takes effect immediately and the impacted user(s) will be logged out of their active session.

e AD and LDAP directory users can be imported and assigned one of the OpenManage Enterprise roles (Admin,
DeviceManager, or Viewer).

e [xecuting device management actions requires an account with appropriate privileges on the device.

Topics:

OpentManage Enterprise user role types

Rale and scope based accoss control in OpenManage Lnterprise

OpenManage Enterprise user role types
@ NOTE:

e AD and LDAF directory users can be imported and assigned one of the OpenManage Enterprise roles (Admin.
DeviceManager, or Viewer).

e Actions run on the devices require a privileged account on the device.

Table 1. OpenManage Enterprise User role types

User with this role... Has the following user privileges
Administrator Has full access to all the tasks that can be performed on the
console.

e Full access (by using GUl and REST) to read, view, create,
edit, delete, export, and remove information related to
devices and groups monitored by OpenManage Enterprise,

e Can create local, Microsoft Active Directory (AD), and
LDAP users and assign suitable roles
Enable and disable users
Madify the roles of existing users

e Delete the users

Security features in OpenManage Enterprise 17



Table 1. OpenManage Enterprise User role types (continued)

User with this role... Has the following user privileges

e Change the user password

Device Manager (DM) e Run tasks, policies. and other actions on the devices
(scope) assigned by the Administrator.

e Can only view and manage entities (jobs, firmware
or configuration templates and baselines, alert policies,
profiles, and so on) that they have created or have
assigned ownership.

Viewer e Can only view information displayed on OpenManage
Enterprise and run reports.

e By default, has read-only access to the console and all
groups,
e Cannot run tasks or create and manage policies.

@ NOTE:

e |f a Viewer or OM is changed to an Administrator, they get the full Administrator privileges. If a Viewer is changed to a
DM, the Viewer gets the privileges of a DM.
e Any change to the user role takes effect immediately and the impacted user(s) will be logged out of their active session.
e An audit log is recorded when:
o A group is assigned or access permission is changed.
o User role is modified.

Related information

Fole and scope-bhased access control in OpenManage Lnterprise on page 18

Role and scope-based access control in OpenManage
Enterprise

OpenManage Enterprise has Role Based Access Control (RBAC) that clearly defines the user privileges for the three built-in
roles—Administrator, Device Manager. and Viewer. Additionally, using the Scope-Based Access Control (SBAC) an administrator

can limit the device groups that a device manager has access to. The following topics further explain the RBAC and SBAC
features.

Role-Based Access Control (RBAC) privileges in OpenManage Enterprise

Users are assigned roles which determine their level of access to the appliance settings and device management features.
This feature is termed as Role-Based Access Control (RBAC). The console enforces the privilege required for a certain action
before allowing the action. For more information about managing users on OpenManage Enterprise, see Vanage OUpenhlanage
Literprise users on page 157.

This table lists the various privileges that are enabled for each role.

Table 2. Role-based user privileges in OpenManage Enterprise

OpenManage Privilege Description User levels for accessing OpenManage Enterprise
Enterprise features ; —— ; =it
Admin Device Manager Viewer
Appliance setup Global appliance settings invalving Y N N
setting up of the appliance.
Security setup Appliance security settings Y N N
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Table 2. Role-based user privileges in OpenManage Enterprise (continued)

OpenManage Privilege Description User levels for accessing OpenManage Enterprise
Enterprise features e : T — ey
Admin Device Manager Viewer
Alert management Y N N
Fabric management | Fabric actions / management y: N
Network Network actions / management Y N N
managemeant
Group management | Create, read, update and delete Y N N
(CRUD) for static and dynamic
groups
Discovery CRUD for discovery tasks, run Y N N
management discovery tasks
Inventory CRUD faor inventory tasks, run Y N M
management inventory tasks
Trap management Import MIB, Edit trap Y N N
Auto-deploy Manage auto-deploy Y N N
management configuration operations
Monitoring setup Alerting policies, forwarding. Y Y N
Services (formerly
SupportAssist ), and so on.
Power control Reboot / cycle device power Y Y N
Device configuration | Device configuration, application Y Y N
of templates, manage/migrate 10
identity, storage mapping (for
storage devices), and so on.
Operating system Deploy operating system, map to Y Y N
deployment LUN, and so on.
Device update Device firmware update, Y Y N
application of updated baselines,
and so on.
Template Create / manage templates Y Y N
management
Baseline Create / manage firmware / Y Y N
management configuration baseline policies
Power management | Set power budgets Y Y N
Job management Job execution / management Y Y N
Report management | CRUD operations on reports Y Y N
Report run Run reports Y Y Y
View View all data, report execution / ¥ Y Y
management, and so on.

Scope-Based Access Control (SBAC) in OpenManage Enterprise

With the use of Role-Based Access Control (RBAC) feature, administrators can assign roles while creating users. Roles
determine their level of access to the appliance settings and device management features. Scope-based Access Control (SBAC)
is an extension of the RBAC feature that allows an administrator to restrict a Device Manager role to a subset of device groups
called scope.

Security features in OpenManage Enterprise 19



While creating or updating a Device Manager (DM) user, administrators can assign scope to restrict operational access of DM to
one or more system groups, custom groups, and / or plugin groups.

Administrator and Viewer roles have unrestricted scope. That means they have operational access as specified by RBAC
privileges to all devices and groups entities.

Scope can be implemented as follows:

1. Create or Edit User

2. Assign DM role

3. Assign scope 1o restrict operational access

For more information about managing users, see Manage UpeniManage Lnterpnse users on page 157,

A natural outcome of the SBAC functionality is the Restricted View feature. With Restricted View, particularly the Device

Managers will see only the following:

e Groups (therefore, the devices in those groups) in their scope.

e [Entities that they own (such as jobs, firmware or configuration templates and baselines, alert policies. profiles, and so on).

e Community entities such as |dentity Pools and VLANs which are not restricted to specific users and can be used by everyone
accessing the consaole.

e Built-in entities of any kind.

It should be noted that if the scope of a Device Manager is 'unrestricted’, then that Device Manager can view all the devices

and groups. however, would only be able to see the entities owned by him/her such as jobs, alert policies, baselines, and so on
along with the community and built-in entities of any kind.

When a Device Manager (DM) user with an assigned scope logs in, the DM can see and manage scoped devices only. Also,

the DM can see and manage entities such as jobs, firmware or configuration templates and baselines, alert policies, profiles and
50 on associated with scoped devices, only if the DM owns the entity (DM has created that entity or is assigned ownership

of that entity). For more information about the entities a DM can create, see Role-Based Access Control (RBAC) privileges in
OpenManage Enterprise.

For example, by clicking Configuration > Templates, a DM user can view the default and custom templates owned by the DM
user. Also, the DM user can perform other tasks as privileged by RBAC on owned templates.

By clicking Configuration > Identity Pools, a DM user can see all the identities created by an administrator or the DM user,
The DM can also perform actions on those identities specified by RBAC privilege. However, the DM can only see the usage of
those identities that are associated to the devices under the DM's scope.

Similarly, by clicking Configuration > VLANs Pools, the DM can see all the VLANSs created by the admin and export them. The

DM cannot perform any other operations. If the DM has a template, it can edit the template to use the VLAN networks, but it
cannot edit the VLAN network.

In OpenManage Enterprise. scope can be assigned while creating a local or importing AD/LDAP user. Scope assignment for
OIDC users can be done only on Open 1D Connect (OIDC) providers.

SBAC for Local users:

While creating or editing a local user with DM role, admin can select one or more device groups that defines the scope for the
BV

For example, you (as an administrator) create a DM user named dm/1 and assign group g7 present under custom groups. Then

dm1 will have operational access to all devices in g7 only. The user dm1 will not be able to access any other groups or entities
related to any other devices.

Furthermore, with SBAC, dm1 will also not be able to see the entities created by other DMs (let's say dm2) on the same group
g71. That means a DM user will only be able to see the entities owned by the user.

For example. you (as an administrator) create another DM user named dm2 and assign the same group g! present under custom
groups. If dm2 creates configuration template, configuration baselines, or profiles for the devices in g7, then dm1 will not have
access to those entities and vice versa.

A DM with scope to All Devices has operational access as specified by RBAC privileges to all devices and group entities owned
by the DM.

SBAC for AD/LDAP users:

While importing or editing AD/LDAP groups, administrators can assign scopes to user groups with DM role. If a user is a member

of multiple AD groups, each with a DM role, and each AD group has distinct scope assignments, then the scope of the user is
the union of the scopes of those AD groups.

For example,

e User dmiis a member of two AD groups (RR5-Floorl-LabAdmins and RR5-Floor3-LabAdmins). Both AD groups have been
assigned the DM role. with scope assignments for the AD groups are as follows: RRS5-Floorl-LabAdmins gets ptlab-servers

20 Security features in OpenManage Enterprise



and RR5-Floor3-LabAdmins gets smdlab-servers. Now the scope of the DM dm1 is the union of ptlab-servers and smdlab-
servers.

e User dmlis a member of two AD groups (odg? and adg2). Both AD groups have been assigned the DM role, with scope
assignments for the AD groups as follows: adg? is given access to g1 and adgZ is given access to g2. If glis the superset of
g2, then the scope of dmf1 is the larger scope (g, all its child groups, and all leaf devices).

When a user is a member of multiple AD groups that have different roles, the higher-functionality role takes pracedence (in the
order Administrator, DM, Viewer).

A DM with unrestricted scope has operational access as specified by RBAC privileges to all device and group entities.
SBAC for OIDC users:

Scope assignment for OIDC users does not happen within the OME console. You can assign scopes for QIDC users at an OIDC
provider during user configuration. When the user logs in with OIDC provider credentials, the role and scope assignment will

be available to OME. For mare information about configuring user roles and scopes, see Configure an Openll) Connect provider
pohiey in Pingkederate for role based access to OpenManage Enterprise on page 170.

(D NOTE: If PingFederate is being used as the OIDC provider, then enly administrator roles can be used. For more

information, see (.l migure an ':j-‘}_l‘-'_"l 0O Cannect [algeiniats]] 1'—'.'_.:|!!'.-,f 11 F'!.’]If_]|"| wlerate fon role based access 1o I'__'r| wanManaoe
Lnterprse on page 170 and the Release Notes at hitps://www dell com/suppor t/hame/en yi I/ product - support/product /
dell openmanage enterprisce/docs,

Transfer ownership : The administrator can transfer owned resources from a device manager (source) to another device
manager. For example, an administrator can transfer all the resources assigned from a source dm1 to dm2. A device manager
with owned entities such as firmware and/or configuration baselines, configuration templates, alert policies, and profiles is
considered an eligible source user, Transfer of ownership transfers only the entities and not the device groups (scope) owned
by a device manager to another. For more information see, Transfer of ownerstup of Device Marager entties on page 164,

Related references

OpenManage Lnterprise user role types on page 17
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Install OpenManage Enterprise

Dell EMC OpenManage Enterprise is provided as an appliance that you can install on a hypervisor and manage resources to
minimize downtime. The virtual appliance can be configured from the application web console after initial network provisioning
in the Text User Interface (TUI). For steps to view and update the console version, see Check and update the version of the
Hpenivianage Enterprse and the available plugins on page 178. This chapter describes the installation prerequisites and minimum
requirements.

@ NOTE: For information about supported browsers, see the OpenManage Enterprise Support Motrix available on the support

site.
Topics:
. Inatallation prérequisites and minimum requirements

= Deploy OpeniManage tnterprise on VMware vSphere

. Deploy Opor

age eEnterprise on Hyper V 2012 K2 and earlier host

. Deploy OpenManage Enterprise on Hyper Vv 2016 host

gl

\

*  Deploy OpenManage Enterprise on Hyper V 2019 or Windows 2022 host

. Deploy Opentla

age Lnterpnse by using Kerngl based Virtual Machine

. Deploy Dpentarage Enterprise programmatically

Installation prerequisites and minimum requirements

For a list of supported platforms, operating systems, and browsers, see the Dell EMC OpenManage Enterprise Support Matrix
on the support site and Dell TechCenter,

To install OpenManage Enterprise, you require local system administrator rights and the system you are using must meet the
criteria mentioned in the Minimum recommaendead hardware and Minimum system reguirements tor mnstalli g OpeniManange

Lnterprise,

Hardware requirements

Lists the minimum hardware requirements for the OpenManage Enterprise appliance.

Table 3. Hardware requirements

Hardware configuration Large deployments Small deployments
Number of devices that can be Up to 8000 1000
managed by the appliance
RAM 32 GB 16 GB
Processors 8 cores total 4 cores total
Hard drive 400 GB 400 GB
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Minimum system requirements for deploying OpenManage
Enterprise

Table 4. Minimum requirements

Particulars Minimum requirements

Supported hypervisors e VMware vSphere versions:
o vSphere ESXi 5.5 onwards
e Microsoft Hyper-V supported on:
o Windows Server 2012 R2 onwards
e KVM supported on;
o Red Hat Enterprise Linux 6.5 onwards

Network Available virtual NIC which has access to the management
networks of all the devices which is managed from
OpenManage Enterprise,

Supported browsers

e Internet Explorer (64-bit) 11 and later

e Mozilla Firefox 52 and later

e Google Chrome 58 and later

e Microsoft Edge version 41.16299 and later
User interface HTML 5, JS based

@ NOTE: For the latest update about the minimum requirements for OpenManage Enterprise, see the Dell EMC OpenManage

Enterprise Support Matrix on the support site.

Deploy OpenManage Enterprise on VMware vSphere

Prerequisites
@ NOTE: To perform any tasks on OpenManage Enterprise, you must have necessary user privileges. See ole and scope
based access contioh i OpenManage Enterprise on page 18.

@ NOTE: If a secondary adapter is added before powering on the appliance for the first time, the adapter will be configured
with IPv4 and IPv6 disabled. Upon login to the TUI, and after accepting the EULA and changing the admin password, the
adapter will show up as DISABLED and must be configured by the user.

Steps

1. Download the openmanage enterprise ovf format.zip file from the support site and extract the file to a location
accessible by VMware v3phere Client. It is recommended to use a local drive or CD/DVD, because installing from a network
location can take up to 30 minutes.

2. Right-click any inventory object that is a valid parent object of a virtual machine, such as a data center, folder, cluster,
resource pool, or host, and select Deploy OVF Template.

3. On the Select an OVF template page, specify the location of the source OVF template and click Next,
(D NOTE: If you are using VMware vSphere vB8.0 or the earlier versions, you must install the Client Integration plug-in
before you deploy an OVF template. Then, in vSphere Client select File > Deploy OVF Template.

The Deploy OVF Template wizard is displayed.

On the Source page, click Browse, and then select the OVF package. Click Next.

On the OVF Template Details page, review the information that is displayed. Click Next.

On the End User License Agreement page, read the license agreement and click Accept. To continue, click Next,

On the Name and Location page, enter a name with up to 80 characters, and then select an inventory location where the
template will be stored. Click Next.

N oo s

8. Depending on the vCenter configuration, one of the following options is displayed:

e
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9.
10.

1.

D

e |f resource pools are configured — On the Resource Pool page, select the pool of virtual servers to deploy the
appliance VM.

e |f resource pools are NOT configured — On the Hosts/Clusters page, select the host or cluster on which you want
to deploy the appliance VM.

if there are more than one datastores available on the host, the Datastore page displays such datastores. Select the

location to store virtual machine (VM) files, and then click Next.

On the Disk Format page. click Thick provision to pre-allocate physical storage space to VMs at the time a drive is

created.

On the Ready to Complete page, review the options you selected on previous pages and click Finish to run the deployment

job.

A completion status window displays where you can track job progress.

eploy OpenManage Enterprise on Hyper-V 2012 R2

and earlier host

Prerequisites

@®

NOTE:

e To perform any tasks on OpenManage Enterprise, you must have necessary user privileges. See Hole and ccope-based
access contral in OpenManage Enterprise on page 18

e |f a secondary adapter is added before powering on the appliance for the first time, the adapter will be configured with
IPv4 and |Pv6 disabled. Upon login to the TUI, and after accepting the EULA and changing the admin password, the
adapter will show up as DISABLED and must be configured by the user.

e After installing or upgrading the appliance on Hyper-V, power off the appliance, remove the standard network adapter
and add a legacy network adapter, and then power on the appliance.

Steps

1

&

10.

.

Download the openmanage_enterprise_vhd_format.zip file from the support site. Extract the file and then move or
copy the enclosed VHD file into an appropriate location on your system where you want to store the OpenManage Enterprise
virtual drive.

Start the Hyper-V Manager in the Windows Server 2012 R2 or an earlier version. The Windows Hyper-V should be

displayed under the Hyper-V Manager. If not, right-click Hyper-V Manager, and then select Connect to Server.

Click Actions > New > Virtual Machine to start the New Virtual Machine Wizard.

Click Next on the initial Before You Begin page.

On the Specify Name and Location page

e provide the Virtual machine name.

e (Optional) Select the Store the virtual machine in a different location check box to activate the Location field, and
then browse and navigate to capture a folder location where the VM would be stored.

@[ NOTE: If the check box is not selected. the VM is stored in the default folder.

Click Next
On the Specify Generation page, select Generation 1 and click Next.
@‘ NOTE: OpenManage Enterprise does not support Generation 2.

On the Assign Memory page, enter the startup memory in the Startup memory field and click Next,

@‘ NOTE: Ensure that a minimum of 16,000 MB (16 GB) is assigned.

On the Configure Networking page, select the network adapter in the Connection drop-down list. Ensure that the virtual
switch is connected to the network. Click Next,

@ NOTE: If set to 'Not Connected'. OME will not function properly during the first reboot, and requires redeployment if

this situation recurs.
On the Connect Virtual Hard Disk page, select Use an existing virtual disk drive, and then browse to the location
where the VHD file is copied as mentioned in step 1. Click Next.

Complete the on-screen instructions.
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12.
13,

D

(DI NOTE: Make sure to have a minimum storage size of 20 GB

Open the Settings of the newly created VM and power on the VM,

On the TUI screen, accept the EULA and when prompted, change the password of the appliance and set network
parameters to the |P of the appliance.

eploy OpenManage Enterprise on Hyper-V 2016 host

Prerequisites

®

NOTE:

e To perform any tasks on OpenManage Enterprise, you must have necessary user privileges. See Role and scope-base
access control in OpenhManage Enterprise on page 18

e |[f a secondary adapter is added before powering on the appliance for the first time, the adapter will be configured with
IPv4 and IPvEB disabled. Upon login to the TUI, and after accepting the EULA and changing the admin password, the
adapter will show up as DISABLED and must be configured by the user.

e After installing or upgrading the appliance on Hyper-V, power off the appliance, remove the standard network adapter
and add a legacy network adapter, and then power on the appliance.

Steps

1

10.

.

12.
13.

Download the openmanage_enterprise_vhd_format.zip file from the support site. Extract the file and then move or copy
the enclosed VHD file into an appropriate location on your system where you want to store the OpenManage Enterprise
virtual drive.

Start the Hyper-V Manager in the Windows server 2016. The Windows Hyper-V should be displayed under the Hyper-V
Manager. If not, right-click Hyper-V Manager, and then select Connect to Server.

Click Actions > New > Virtual Machine to start the New Virtual Machine Wizard.

. Click Next on the initial Before You Begin page.
. On the Specify Name and Location page

e provide the Virtual machine name.

e (Optional) Select the Store the virtual machine in a different location check box to activate the Location field, and
then browse and navigate to capture a folder location where the VM would be stored.

@‘ NOTE: If the check box is not selected, the VM is stored in the default folder.
Click Next

On the Specify Generation page. select Generation 1 and click Next.

(D' NOTE: OpenManage Enterprise does not support Generation 2.

On the Assign Memory page, enter the startup memory in the Startup memory field and click Next,

(D|NOTE: Ensure that a minimum of 16,000 MB (16 GB) is assigned.

On the Configure Networking page, select the network adapter in the Connection drop-down list. Ensure that the virtual
switch is connected to the network. Click Next.

C[) NOTE: If set to 'Not Connected'. OME will not function properly during the first reboot, and requires redeployment if
this situation recurs.

On the Connect Virtual Hard Disk page, select Use an existing virtual disk drive, and then browse to the location
where the VHD file is copied as mentioned in step 1. Click Next.

Complete the on-screen instructions.
@I NOTE: Make sure to have a minimum storage size of 20 GB

Open the Settings of the newly created VM and power on the VM.

On the TUI screen, accept the EULA and when prompted. change the password of the appliance and set network
parameters to the IF of the appliance.

ha
(4]
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eploy OpenManage Enterprise on Hyper-V 2019 or

Windows 2022 host

Prerequisites

®

NOTE:

e To perform any tasks on OpenManage Enterprise, you must have necessary user privileges. See Role and scope basod
access control in OpeniManage Enterprise on page 18

e |f a secondary adapter is added before powering on the appliance for the first time, the adapter will be configured with
IPv4 and IPvEB disabled. Upon login to the TUI, and after accepting the EULA and changing the admin password, the
adapter will show up as DISABLED and must be configured by the user.

e After installing or upgrading the appliance on Hyper-V, power off the appliance, remove the standard network adapter
and add a legacy network adapter, and then power on the appliance.

Steps

L

2

Download the openmanage_enterprise_vhd_format.zip file from the support site. Extract the file and then move or copy
the enclosed VHD file into an appropriate location on your system where you want to store the OpenManage Enterprise
virtual drive.

Start the Hyper-V Manager. The Windows Hyper-V should be displayed under the Hyper-V Manager. If not, right-click
Hyper-V Manager, and then select Connect to Server,

Click Actions > New > Virtual Machine 1o start the New Virtual Machine Wizard.
Click Next on the initial Before You Begin page.

On the Specify Name and Location page

e provide the Virtual machine name.

e (Optional) Select the Store the virtual machine in a different location check box to activate the Location field, and
then browse and navigate to capture a folder location where the VM would be stored.

@! NOTE: If the check box is not selected, the VM is stored in the default folder.

6. Click Next

10.

.

12.
13.

On the Specify Generation page, select Generation 1 and click Next.
@’ NOTE: OpenManage Enterprise does not support Generation 2.

On the Assign Memory page, enter the startup memory in the Startup memory field and click Next.
@‘ NOTE: Ensure that a minimum of 16,000 MB (16 GB) is assigned.

On the Configure Networking page, select the network adapter in the Connection drop-down list. Ensure that the virtual
switch is connected to the network. Click Next.

@ NOTE: If set to 'Not Connected'. OME will not function properly during the first reboot, and requires redeployment if

this situation recurs.
On the Connect Virtual Hard Disk page. select Use an existing virtual disk drive. and then browse to the location
where the VHD file is copied as mentioned in step 1. Click Next.

Complete the on-screen instructions.
@‘ NOTE: Make sure to have a minimum storage size of 20 GB

Open the Settings of the newly created VM and power on the VM.

On the TUI screen, accept the EULA and when prompted, change the password of the appliance and set network
parameters to the IP of the appliance.

Install OpenManage Enterprise



Deploy OpenManage Enterprise by using Kernel-based
Virtual Machine

Prerequisites

@ NOTE:

e To perform any tasks on OpenManage Enterprise, you must have necessary user privileges. See Kol and scope hasod
access control in OpenManage knterprise on page 18

¢ If a secondary adapter is added before powering on the appliance for the first time, the adapter will be configured with

IPv4 and IPv6 disabled. Upon login to the TUI, and after accepting the EULA and changing the admin password, the
adapter will show up as DISABLED and must be configured by the user,

Steps
1. Install the required virtualization packages while installing the operating system.

2. Download the openmanage enterprise kvm format.zip file from the support site. Extract the file to an appropriate
location on your system where you want to store the OpenManage Enterprise virtual drive.

Start the virtual manager and select File > Properties.

On the Network Interfaces page, click Add.

Select Bridge as the interface type and click Forward.

Set the start mode to onboot and select the Activate now check box.

Select the interface to bridge from the list and ensure the properties match with the host device, and then click Finish.
A virtual interface is now created, and you can configure the firewall settings by using the terminal.

On the Virtual Machine Manager, click File > New.

9. Enter a name for the VM and select the Import existing disk image option, and then click Forward.

10. Navigate the file system and select the QCOW?2 file that is downloaded in step 1, and then click Forward.
1. Assign 16 GB as the memory and select two processor cores, and then click Forward.

12. Assign the required disk space for the VM and click Forward.

No oS o

@

13. Under Advanced options, ensure that the bridged host device network is selected and KVM is selected as the Virt Type.

14. Click Finish.
OpenManage Enterprise appliance is now deployed by using the KVM. To get started with OpenManage Enterprise, see | 0
in to UpeniManage Cnterprise on page 29.

Deploy OpenManage Enterprise programmatically

OpenManage Enterprise can be deployed programmatically (using a script) on VMWare ESXi version 8.5 or later.

Prerequisites
@‘ NOTE: Programmatic/scripted deployment is only supported using the primary interface.

@ NOTE: If a secondary adapter is added before powering on the appliance for the first time, the adapter will be configured
with IPv4 and IPvE disabled. Upon login to the TUI, and after accepting the EULA and changing the admin password, the
adapter will show up as DISABLED and must be configured by the user.

@I NOTE: You must use the latest versions of OVF Tool and Python 3.0 or later for the programmatic deployment.

To programmatically deploy OpenManage Enterprise, do the following:

Steps

1. Download and extract the openmanage enterprise ovf format.zip file or download the following OVF files
individually from the support site:
® openmanage enterprise.x86 64-0.0.1-diskl.vmdk
® openmanage enterprise.x86_64-0.0.1.mf

=
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3. Runthe update ovEf property.py script.

® openmanage enterprise.x86 64-0.0.1.0vf

openmanage enterprise.x86 64-0.0.1.vmx

e ovf properties.config

® update ovf property.py

Openthe ovf properties.config and set the following parameters:

Table 5. Parameters used in ovf properties.config

Parameter

Accepted Values

Description

bEULATxt

true or false

By setting this value to true, you agree
to the terms and conditions in the End-
User License Agreement (EULA). The
EULA is available at the bottom of the
ovf_properties.config file.

adminPassword

Must contain at least

one character in: uppercase,
lowercase, digit, and special
character. For example, Dell123%

Type a new administrator password for
the OpenManage Enterprise.

bEnableDHCP

true or false

Set to true if you want the appliance
to enable IPv4 DHCP and to ignore the
static IPv4.

bEnablelpvBAutoConfig

true or false

Set to true if you want the appliance
to enable |Pv6 auto configuration and to
ignore the static IPvB.

staticlP

static IP in CIDR format

Can be IPv4 or IPvB. (You cannot set
both the |Pv4 and IPvE types at a time,)

gateway

IPv4 or IPvB

You cannot set static Gateway as IPv4
and IPvB types at a time.

This script modifies the openmanage enterprise.x86_64-0.0.1.ovf file for deployment in accordance with the
values set in the ovf_properties.config file. When the script finishes execution, a sample ovftool command is displayed. It

c ¢ (

(

p

contains tags such as <DATASTORE>, <user>, <password>, <IP address>, and so on, that you must replace as
per your deployment environment. These settings define the resources that are used on the target ESXi system and also the
credentials and IP address of the target system.

@l NOTE: Remember to replace the entire tag including the < and > symbols.

4. Run the modified ovftool command frem the previous step.

0

NOTE: The ovftool command must be run with the --X:injectOvfEnv and --powerOn flags because they are required for
programmatic deployment.

After the ovftool command is run, the manifest validates and the deployment begins.
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Get started with OpenManage Enterprise

Topics:

*  Loginte OpenhManage Coterprise

. Configurs OUpenhd Lnterprise by using Text User Interface

o Lonfigue ge Lnterprise

¢ Recommended scalability and performance settngs for optimal usage of Openianage Enterprise
*  Supported protocols and ports in OpenManage Enterprise

. Use case links for the supparted pratocols and ports in OpenManage Lnterprise

Log in to OpenManage Enterprise

About this task

When you boot the system fer the first time from the Text User Interface (TUI), you are prompted to accept the EULA, and
then change the administrator password. If you are logging in to OpenManage Enterprise for the first time, you must set the

user credentials through the TUI See Configure OpenManage Enterpnse by using Text User Interface on page 29.
1" If you forget the administrator password, it cannot be recovered from the OpenManage Enterprise
appliance.
Steps

1. Start the supported browser.
2. Inthe Address box. enter the OpenManage Enterprise appliance |P address.

On the login page, OpenManage Enterprise logo and a security notice stating 'By accessing the computer, you confirm that
such access complies with your organization's security policy,' is displayed. The security notice can be customized by the
administrators using APl For more information, see the OpenManage Enterprise AP| Guide.

3. Type the login credentials, and then click Log in.

@l NOTE: The default user name is admin.

Next steps

If you are logging in to OpenManage Enterprise for the first time, the Welcome to OpenManage Enterprise page is displayed.
Click Initial Settings. and complete the basic configuration setup. See Contigur: Cpenianage Lotorpnse on page 33, To
discover the devices, click Discover Devices.
@ NOTE: By default, after three failed login attempts, your OpenManage Enterprise account gets locked and you cannot

log in until the account lockout duration is over. The account lockout duration is 900 seconds by default, To change this

duration, see Sct the login secunity properties on page 175.

Configure OpenManage Enterprise by using Text User
Interface

The Text User Interface (TU!) tool provides a text interface to change the Administrator password, view appliance status and
network configuration, configure networking parameters, enable field service debug request, select the primary network, and to
configure the appliance for automatic discovery of the servers in your network.

When you boot the system for the first time from the TUI, you are prompted to accept the End User License Agreement
(EULA). Next, change the administrator password and configure network parameters for the appliance and load the
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web console in a supported browser to get started. Only users with OpenManage Administrator privileges can configure
OpenManage Enterprise.

On the TUl interface, use the arrow keys or press Tab to go to the next option on the TUI, and press Shift + Tab to go back to
the previous options. Press Enter to select an option. The Space bar switch the status of a check box.

(D NOTE:

e To configure IPvB, ensure that it is already configured by a vCenter server,

e By default, the last discovered IP of a device is used by OpenManage Enterprise for performing all operations. To make
any IP change effective, you must rediscover the device.

You can configure OpenManage Enterprise by using the TUL. The TUI screen has the following options:

Table 6. Text User Interface options

Options Descriptions

Change the Admin Password Select Change the Admin Password screen to enter a new
password and confirm the password.

For the first time, you must change the password by using the
TUI screen.

Display Current Appliance Status Select Display Current Appliance Status to view the URL
and the status of the appliance. You can also view statuses of
the Task Execution, Event Processing, Tomcat, Database, and
Menitoring services.

Display Current Network Configuration Select Display Current Network Configuration to view the
IP configuration details.

Choose Network Adapter menu lists all the available
network adapters. Clicking on a network adapter will display
its current settings.

Set Appliance Hostname Select Set Appliance Hostname to configure the appliance
hostname on the DNS. This field supports the following valid
characters for host names: alphanumeric (a-z, A-Z, 0-9),
periods (. ), and dashes ( - ).

(i)|NOTE: Using periods will designate domain name
information. If the appliance DNS information is configured
statically rather than getting domain details frem DHCF,
you must configure the hostname using the fully qualified
domain name (FQDN) so that the domain search
information can be populated.

Set Networking Parameters Select Set Networking Parameters to reconfigure the
network adapters.

Choose Network Adapter menu lists all the available
networks adapters. Select a network adapter, reconfigure its
netwark parameters, and select Apply to save the changes to
the appropriate interface.

By default, only IPv4 is enabled on primary network interface
with a private static IP in the appliance. However, if a new
network interface is added, both IPv4 and IPv6 are enabled
for multihoming.

If the OpenManage Enterprise appliance fails to acquire a
IPvB address. check if the environment is configured for
router advertisements to have the managed bit (M) turned
on. Network Manager from current Linux distributions causes
a link failure when this bit is on, but DHCPvE is not available.
Ensure that DHCPvE is enabled on the network or disable the
managed flag for router advertisements.

®|NOTE:
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Table 6. Text User Interface options (continued)

Options

Descriptions

e DNS configuration is only available on the primary
network interface. If DNS resolution is wanted on this
interface, all host names must be resolvable by the
DNS server configured on the primary interface.

e [or more information about multihoming, see the
Multihoming on OpenManage Enterprise technical
whitepaper on the Dell OpenManage Enterprise
suppert site,

Select Primary Network Interface

Select Primary Network Interface allows you to designate
a primary network.

Primary interface selection gives priority to the selected
interface in terms of routing and is used as the default route.
This interface will have the routing priority if there is any
ambiguity. The primary interface is also expected to be the
'public facing' interface which allows for corporate network/
internet connectivity. Different firewall rules are applied to the
primary interface, which allow for tighter access control such
as access restriction by |P range.

(D|NOTE: If multihoming is enabled, the appliance can

be accessed from two networks, In this case, the
primary interface is used by the appliance for all external
communication and when proxy settings are used. For
more information about multihoming, see the Multihoming
on OpenManage Enterprise technical whitepaper on the
Dell OpenManage Enterprise support site.

Configure Static Routes

Select Configure Static Routes if the networks require a

static route to be configured to reach a specific subnet over

the IPv4 and IPvE networks.

(DINOTE: A maximum of 20 static routes per interface is
supported.

Select Configure Server Initiated Discovery to allow the
appliance to automatically register the required records with
the configured DNS server.

(D|NOTE:

e Ensure that the appliance is registered with DNS, and
can dynamically update records.

e [he target systems must be configured to request
registration details from DNS,

e To change the DNS Domain Name, ensure Dynamic
ONS registration is enabled on the DNS server. Also,
for appliance to be registered on the DNS server,
select the Nonsecure and secure option under
Dynamic updates.

Configure Appliance Disk Size

availability of disk space or new disk(s) and then allocate the
additional disk space or disk(s) for the appliance if required.
(D{NOTE:

e [tis highly recommended to take a VM snapshot of
the console as a backup before applying any disk
configuration changes.

e Post addition of the disk space, deletion or reduction
of the expanded disk space is not supported. To
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Table 6. Text User Interface options (continued)

Options

Descriptions

remove a newly added disk or to reverse the increase
in size of an existing disk you must revert to prior VM
snapshot.

e |f the initial scan detects no unallocated space, then
allocate additional disk space or disks to the console on
your hypervisor and rescan.

e Scanning and allocation of disk space is limited to a
maximum of four disks.

Enable Field Service Debug (FSD) Mode

Restart Services

Select Enable Field Service Debug (FSD) Mode (default)
for console debugging using HTTPS. For more information,
see Held service debug workflow on page 194,

Select Restart Services with the following options to restart
the services and networking:
e Restart All Services

¢ Restart Networking

Setup Debug Logging

Enable CIFS share for FSD (emergency use only)

Select Enable CIFS share for FSD (emergency use only)

Select Setup Debug Logging using the following options :
e Enable All Debug Logs
o 1o collect the Debug logs of the all the application
monitoring tasks, events, the task execution history,
and installed plugins.
¢ Disable All Debug Logs
o to disable all the Debug logs.
e Configure Debug Logging
o To selectively enable debug logging for appliance and
plugin services.
o Use the Options menu to select all services, clear
all selections or restore state prior to making any
modifications.
e Enable SCP Retention—to collect the template XML
files.
()| NOTE: SCP file retention is not applicable for MX7000
chassis templates.
e Disable SCP Retention—1to disable the SCP retention.

You can create a console log archive from the Monitor

> Audit Logs page by clicking Troubleshoot > Create
Console Log Archive. To download the archived console log,
click Troubleshoot > Download Archived Console Logs.

for console debugging using CIFS share. For more information,
see Held service debug workflow on page 194.

Change keyboard layout

Select Change keyboard layout to change the keyboard
layout if needed.
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Select Reboot the Appliance to restart the appliance.
(i)|NOTE: After running a command to restart the services,
the TUI may display the following message; NMI
watchdog: BUG: soft lockup - CPU#0 stuck
for 36s! [jJava:14439].

The soft lockup issue likely occurs as a result of the
hypervisor being overloaded. In such situations, it is
recommended to have at least 16 GB of RAM and CPU
of 8000 MHz reserved to the OpenManage Enterprise
appliance. It is also recommended that the OpenManage




